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Glossary 

 

Term or acronym Definition or description 

alternative Increasing the placement capacity of a system by acquiring or leasing additional 
placement sites. 

criterion Most commonly, the economic price of moving or placing material. However, 
environmental, social, or other costs can be used as an alternative. D2M2 does not 
mix or combine costs of different categories. 

AHP Analytic Hierarchy Process 

D2M2 The original dredged material disposal management software application. It is a 
DOS program that was developed by the Hydrologic Engineering Center of the 
Corps of Engineers. The program subsequently was modified for the San Francisco 
District; it remained a DOS program with a character-based user interface. 

MAUT Multi-Attribute Value Theory 

MAVT Multi-Attribute Utility Theory 

PROMETHEE Preference Ranking Organization METHod for Enrichment Evaluations 
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Overview of D2M2 

D2M2 is dredged-material disposal management software that was developed for the US Army Corps of 
Engineers (USACE), San Francisco District. This is a recent revision of the software that was orinally developed 
at the Hydrologic Engineering Center (HEC) of the USACE.  
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User Interface 

D2M2-DSS provides a user-friendly graphical interface that includes following components: 

1. Main Menu Bar 
2. Main Toolbar 
3. Value tree panel 
4. Performance table panel 
5. Properties panel 

 

Figure 1.1. User Interface 



7 

 

Menus 

File Menu 

The File menu provides following options: 

 New Project. Creates a new project file. 
o User defined. User begins with empty criteria tree and must specify new project structure 

(criteria, alternatives, etc.) by him/her-self. 
o Solutions assessment (LPS). Loads the LPS module solutions report and asks user to 

choose solutions and criteria for assessment. (Scores will be loaded automatically). 
o Equipment assessment (LPS). Loads the LPS module project and asks user to choose 

equipment and criteria for assessment. (Scores will be loaded automatically). 
o Dredge sites assessment (LPS). Loads the LPS module project and asks user to choose 

dredge sites and criteria for assessment. (Scores will be loaded automatically). 
o Disposal sites assessment (LPS). Allows disposal and transfer sites analysis. 

 Primary screening. Loads the LPS module project and asks user to choose 
disposal/transfer sites and criteria for primary screening. (No scores defined). 

 Secondary screening. Loads the LPS module project and asks user to choose 
disposal/transfer sites and criteria for secondary screening. (No scores defined). 

 Custom analysis. Loads the LPS module project and asks user to choose 
disposal/transfer sites and criteria for assessment. (Scores will be loaded 
automatically). 

o Sites assessment (GIS). Loads the GIS module sites report and asks user to choose sites 
and criteria (layer attributes) for assessment. (Scores will be loaded automatically). 

 Open Project. Opens an existing project file. Currently opened project file will be closed prompting 
a user that it should be saved to prevent loss of data. 

 Save Project. Saves the current project under the same name in the same location. Saves any new 
changes over the original project file you opened. If a file is newly created, then Save will open a 
dialog allowing you to name the file and choose a save location. Otherwise, it is a simple save of 
the current information over the old, in the same place with the same name. When the project file 
is saved, the program prompts for a project description. 

 Save Project As. Saves the current project with a new project name. D2M2-DSS asks for a new 
location and project filename. Save Project As will always bring up the Save Project As dialog 
allowing you to change the file name and it’s save location. This allows you to keep the original file 
intact in its original location, which is useful if you would like to make a change to the network and 
compare the results. 

 Export. Exports the current project data/result to existing files. 
o Primary screening. Saves ranking by current method as a result of disposal sites primary 

screening. 
o Secondary screening. Saves ranking by current method as a result of disposal sites 

secondary screening. 

 Exit. Exits from the D2M2 software. 

 

Edit Menu 

Using your mouse you can select one or more items. The Edit menu provides these options:  

 Undo. Undoes the last action performed. 

 Redo. Redoes or returns the action that was undoes earlier. 

 Copy. Copies selected items into the clipboard.  

 Paste. Pastes items that was copied or cut earlier. 
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 Cut. Cuts selected items into the clipboard. 

 Delete. Deletes selected items. 
 

View Menu 

The View menu provides these options:  

 Panels. This menu contains a checklist that includes four elements – application panels. Using 
the checklist, you can enable or disable these panels on the workspace. 

 

Model Menu 

The Model menu provides these options: 

 Select method. Opens a dialog which allows user to choose MCDA method for analysis. 

 Calculate. If all the necessary input data is filled in, you can calculate an overall ranking of alternatives 
(representation form depends on used method). 

 Analysis. Provide walking weights analysis tool for sensitivity analysis. 

 Settings. Allows specifying project settings. 
 

Help Menu 

The Help menu provides these options: 

 User’s Guide. Shows User’s Guide document, such as you read now. 

 About. Shows About box dialog. 
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Toolbar 

Toolbar provides quick access to some functions of D2M2-DSS. 

 

Figure 1.2. Toolbar 

1. New Project 

2. Open Project 

3. Save Project 

4. Undo Action 

5. Redo Action 

6. Cut 

7. Copy 

8. Paste 

9. Delete 

10. Select method 

11. Calculate 

12. Analysis 

13. Settings 

 

All this quick actions provide the same function as the items in menu bar. You can place the toolbar in a 
convenient place. To do this, press the left mouse button on the left side of toolbar, and drag to the desired 
location and then release the mouse button. 



10 

 

Integration with LPS and GIS 

Solutions assessment (LPS) 

Solution assessment option available when you construct new project via File->New-> Solutions assessment 
(LPS).  

 

Figure 1.3. LPS solutions assessment 

 

Using this tool you can assess solutions that you obtain in LPS module by several criteria (it is possible to add 
your own criteria if needed). User interface allow you to move criteria and alternatives from “available” lists to 
“used” lists. Buttons “>>”  and “<<” allow you to enable/disable use of all criteria/alternatives  from list. 

 

Equipment assessment (LPS) 

Equipment assessment option available when you construct new project via File->New->Equipment 
assessment (LPS).  

 

Figure 1.4. LPS equipment assessment 



11 

 

 

Using this tool you can assess equipment mentioned in LPS module by several criteria (it is possible to add 
your own criteria if needed). User interface allow you to move criteria and alternatives from “available” lists to 
“used” lists. Buttons “>>”  and “<<” allow you to enable/disable use of all criteria/alternatives  from list. 

 

Dredge sites assessment (LPS) 

Dredge sites assessment option available when you construct new project via File->New-> Dredge sites 
assessment (LPS).  

 

Figure 1.5. LPS dredge sites assessment 

 

Using this tool you can assess dredge sites mentioned in LPS module by several criteria (it is possible to add 
your own criteria if needed). User interface allow you to move criteria and alternatives from “available” lists to 
“used” lists. Buttons “>>”  and “<<” allow you to enable/disable use of all criteria/alternatives  from list. 

 

Disposal sites assessment (LPS) 

Disposal sites assessment option available when you construct new project via File->New-> Disposal sites 
assessment (LPS)-> Primary screening, Secondary screening or Custom analysis. 
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Figure 1.6. LPS disposal sites assessment 

 

Using this tool you can assess dredge sites mentioned in LPS module by several criteria (it is possible to add 
your own criteria if needed) and export results back to LPS module (see Menus->File Menu section). User 
interface allow you to move criteria and alternatives from “available” lists to “used” lists. Buttons “>>”  and 
“<<” allow you to enable/disable use of all criteria/alternatives  from list. 

 

Sites assessment (GIS) 

GIS sites assessment option available when you construct new project via File->New-> Sites assessment (GIS).  

 

Figure 1.7. GIS sites assessment 

 

Using this tool you can assess sites mentioned in GIS module by several criteria that depends on GIS layer 
attributes (it is possible to add your own criteria if needed). For every criterion aggregation function (MIN, 
MAX, SUM or AVG) must be defined. 
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Workspace 

Value tree panel 

Value Tree (VT) is one of the basic components in any decision support system. D2M2-DSS VT represents 
multi-level criteria tree and alternatives. Every criterion is subdivided to left (properties) part and right 
(scoring) part. You can make double-click to activate properties or scoring dialog respectively and right-click to 
activate pop-up menu with additional operations: add child criterion, delete this criterion, properties, 
weighting/scoring method choosing. Also you can use right-click on empty tree space to activate tree pop-up 
menu with the options: add alternative, arrange tree. When you created a new project, you have only a root 
entry (criterion) in the tree. Then you can build a VT according to your problem. To do this: specify criteria with 
criterion pop-up menu (right click on criterion right area); specify alternatives with tree pop-up menu (right 
click on empty tree space). 

 

 

Figure 2.1. Value tree panel 

 

Adding criterion 

1. Click right mouse button on the parent criterion for new one. 
2. Click “Add criterion” in popup menu. 
3. Specify criterion name. 

 

Adding alternative 

1. Click right mouse button on the free tree space. 
2. Click “Add alternative” in popup menu. 
3. Specify alternative name. 
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Arrange tree 

1. Click right mouse button on the free tree space. 
2. Click “Arrange tree” in popup menu. 

After these actions tree will be arranged with smooth animation. 
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Performance table panel 

Performance Table (PT) displays the values of alternatives for all leaf criteria, criterion weights, and 
additional descriptions. The interface of PT allows adding or deleting alternatives, editing parameters of 
alternatives and criteria. 

 

Figure 2.2. Performance table panel 

 

Selection 

Performance Table supports three types of selection: 

 Column selection is performed by single clicking left mouse button on top cell in the column. 

 Row selection is performed by single clicking left mouse button on first cell in the row. 

 And cell selection is produced by single clicking left mouse button on any other cell in the table. 

 

Structure 

Performance Table consists of two parts: 

 top part represent various information about leaf criteria, 

 bottom part displays criterion values against each alternative. 

Note: Part of table can be collapsed or expanded by clicking left mouse button on the header of the part 
with a title. 

 

Top part and criteria attributes 
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Each column in the table represents information about single leaf criterion, including: 

 criterion name, 

 criterion weight. 

 

Bottom part and alternative scales 

In this part columns represent leaf criteria and rows represent alternatives. Headers of columns display 
criterion names and first cells of rows show the names of alternatives. Other cells display values of alternatives 
against the criteria.  

In any value/score cell left part is represented by a given basic/deterministic value of alternative for this 
criterion and right part contains (if exists) information about (given by user) random value implemented within 
the selected multi-criteria method. 

If random number is used. Right part contains: 

 type if distribution (uniform, normal, delta, log normal), 

 expected value (eg.:”E:0.9”), 

 standard deviation value (eg.:”s:0.19”), 

 left bound of consideration interval (eg.:“L:1.2”), 

 right bound of consideration interval (eg.:“R:4.5”). 

Double-click on score cell will evokes Scores/Performance Dialog for editing scores information. 
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Properties Panel 

 

 

Figure 2.3. Properties panel 

 

Properties panel is used to display the properties of selected item. Using this panel you can adjust 
different properties of any element (criterion or alternative) in project. 

Each Properties panel consists of a set of categories related to the selected object. You can collapse or 
expand the parameters of categories by pressing on the category name. 

Criterion name and description can be changed just by clicking left mouse button on the cell. After that 
editing cursor will appear in the cell. Finishing editing is performed by pressing Enter button or selecting any 
other cell of the table. 

Criterion weight cell represents criterion weight in the current model by means of ordinal 
number(eg:”0,25”), random number (eg:”Rand (E:0,2 s:0,06 L:0,10 R:0,3)”) or “not set” string if not calculated. 

Scale attributes includes several rows: 

 measure units (or “none” if undefined), 

 is scale local or global (local or global), 

 scale min value, 

 scale max value, 

 is scale minimized or maximized (minimize, maximize). 

Bottom part of Properties panel contains Alternatives scores by chosen criterion (if criterion selected) or 
Alternative scores by all leaf criteria (if alternative selected). 
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Method select dialog 

To change the basic properties of your project you have to select the Project element in the Explorer panel 
(the root of the explorer tree). To change the properties enter necessary data in to the following fields. 

Current version of D2M2-DSS support the follows MCDA methods: 

 MAVT 

 AHP 

 PROMETHEE I, II 

 MAUT 

 

 

Figure 2.4. Method selection dialog 
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Settings dialog 

 

 

Figure 2.5. Project settings 

Dialog contains these settings: 

 Significance level. Parameter for confidence intervals calculation. Widely used for probability 
distributions. 

 Accuracy. Number of digits after comma that must be shown (affect all numbers in project; see 
Pattern as example). 

 Best alternatives #. Number of alternatives must be shown in results if there are a lot of 
alternatives. 
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Weighting 

In the D2M2-DSS two weighting methods supported: 

1. Direct weighting. Used in MAVT, PROMETHEE I, II and MAUT methods. 
2. Pairwise comparison. Used in AHP method. 

 

Direct weighting 

In direct weighting you must specify the weight coefficients (as scaling factors) for all child criteria. Just use 
slider in second column or specify the number in third column. Weights sum must be equals 1. It will be done 
automatically after you click “Ok” button or manually if you click “Normalize” button. 

 

 

Figure 2.6. Direct weighting dialog. 

 

Pairwise comparison 

Pairwise comparison used as weighting and scoring mechanism in AHP method. You need to fill matrix of 
relative scores for every pair of elements. Just select the cell in matrix and use vertical slider to specify the 
score for given pair of elements in Saaty scale: 

 9 – Extremely preference 

 7 – Very strong preference 

 5 – Strong preference 

 3 – Moderate preference 
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 1 – Equal 

And the same points for preference of bottom element, but in form 1/x. 

 

 

Figure 2.7. Pairwise comparison dialog. 
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Scoring 

Different MCDA methods realize different scoring mechanisms: 

1. Value function – used in MAVT method. 

2. Preference function – used in PROMETHEE I, II method. 

3. Utility function – the same as Value function, but use random number as argument (used in MAUT 
method). 

 

Value function 

Value function translates the value (performance) from criterion scale to the range [0; 1]. So these scores 
could be used in further calculations. 

 

 

Figure 2.8. Value function in scoring dialog 

 
Next types of value function are supported: 

 Linear 

 Exponential 

 Piecewise – must be constructed by user (click on function to add new point) 
 

Preference function 

Preference function translates the difference between scores for every pair of alternatives to the range [0; 
1]. So these scores could be used in further flows calculations (PROMETHEE methods). 
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Figure 2.92. Preference function in scoring dialog 

 

Next types of preference function are supported: 

 Usual 

 U-Shape 

 V-Shape 

 Level 

 Linear 
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Random values 

MAUT method use random values as alternative scores by criterion. You can specify these values with 
special tool (see picture below). 

 

 

Figure 2.3. Probability tool 

 

Next types of probability distribution are supported: 

 Delta (uses only average value) 

 Uniform (uses only left and right values) 

 Normal (uses average and standard deviation values; left, right if you need to truncate 
distribution) 

 Log-Normal (uses average and standard deviation values; left, right if you need to truncate 
distribution) 
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Project Reports 

D2M2-DSS contains different types of dialogs for different methods. Also it provides sensitivity analysis to 
the weight change. 

Results dialog 

The button “Calculate” invokes the dialog which presents the results of calculation of the current model. It 
is possible to scale the dialog using Mouse device. To close the dialog press the cross button. 

 

MAVT / MAUT / AHP 

 

 

Figure 4.1. MAVT overall report 

 

The dialogs which present the results for MAVT / MAUT / AHP methods is titled "Report(method's name)" 
and have the same structure. 

The dialog consists of two parts: the top one is the Bar Chart labeled "Overall Scores" and the bottom is 
the text field with labeled "Resulting values of alternatives". 

The format is: Name of the Alternative = Score 
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"Overall Scores" is a bar chart with the following Axes: the horizontal one presents the Alternatives and 
the vertical one presents the values of scores. There is the Legend which gives information about used colors. 
It is situated on the right side of the plot area. 

 

PROMETHEE I, II 

 

 

Figure 3.25. PROMETHEE overall report 

 

The dialog for PROMETHEE consists of two parts: the top one is the folder labeled "Flows" and the bottom 
one is the set of tabs with graphs. The folder "Flows" contents one table which displays calculated indexes for 
three types of flows. They are Positive Flow, Negative Flow and Net Flow. The bottom part consists of two tabs 
with PROMETHEE I and PROMETHEE II graphs. 
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Analysis dialog 

Weight sensitivity analysis is a powerful tool for understanding an influence of the assigned weights on the 
output results (eg, ranking alternatives). It is used with the all following methods: MAVT, MAUT, PROMETHEE, 
and AHP. User can choose the criterion for weight sensitivity analysis (left-top part of the dialog); then with 
slider (bottom part of the dialog) user can change weight from 0 to 1 (other weights are automatically changed 
proportionally holding weight sum = 1) and observe possible changes of output results (ranking alternatives). 
There are the two forms for weight sensitivity analysis and representation of the results: Lines form and Bars 
form (walking weights). User can restore base weights values at any moment (see button at the top-right part 
of dialog). 

 

 

Figure 3.3. Analysis- Line weights 
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Figure 3.4. Analysis- Walking weights 

 


