Content
Overview of D2M2 .......................................................................................................................... 3
User Interface ................................................................................................................................. 4
Menus .......................................................................................................................................... 4
  File Menu ................................................................................................................................. 4
  Edit Menu ................................................................................................................................. 5
  View Menu ................................................................................................................................. 5
  Layer Menu ............................................................................................................................... 6
  Analysis Menu ............................................................................................................................ 6
  Tools Menu ................................................................................................................................ 6
  Help Menu .................................................................................................................................. 7
Main Toolbar .................................................................................................................................. 8
Map View Toolbar ......................................................................................................................... 9
Map Edit Toolbar .......................................................................................................................... 10
Map Viewer Pane ........................................................................................................................ 11
Layer Manager ............................................................................................................................. 13
Status Bar ..................................................................................................................................... 14
Projects Management ................................................................................................................ 15
Application Settings .................................................................................................................... 17
Layers Management ..................................................................................................................... 18
Map Tools ................................................................................................................................... 22
  Map Query Builder .................................................................................................................... 22
  Attribute Data Viewer ............................................................................................................... 23
  Spatial Alternatives Manager .................................................................................................... 25
  Network Diagram Builder ......................................................................................................... 27
    Network Diagram Builder – Example of Use ........................................................................... 31
Overview of D2M2

D2M2 is dredged-material disposal management software that was developed for the US Army Corps of Engineers (USACE), San Francisco District. This is a recent revision of the software that was originally developed at the Hydrologic Engineering Center (HEC) of the USACE.
User Interface

D2M2-GIS provides a user-friendly graphical interface that includes following components:

1. **Main Menu Bar**
2. **Main Toolbar**
3. **Map View Toolbar**
4. **Map Edit Toolbar**
5. **Map Viewer**
6. **Layer Manager**
7. **Status Bar**

![D2M2-GIS - Project](image)

*Figure 1. User Interface*

Menus

**File Menu**

- **New Project.** Allows to create a new project. Special dialog will be displayed. It allows to specify project name and description as well as specify list of map layer to load and map units.
- **Open Project.** Allows to load project from the file. If there is open project it will be closed.
- **Close Project.** Closes current project. If project is not saved the confirmation dialog will be displayed.
• **Project Properties.** Display project properties dialog. All project parameters may be changed here including project name and list of loaded map layers.

• **Save Project.** Save project to file. If project is new the open dialog will be displayed to select file for project saving.

• **Save Project As.** Allows to save current project as a new one.

• **Settings.** Allows to manage application settings.

• **Exit.** Closes application.

**Edit Menu**

• **Undo.** Undo last editing operation.

• **Redo.** Redo last editing operation.

• **Add Feature.** Turns add features mode on. In this mode a new feature may be created by the left mouse clicking on the map. To end a new feature creation double click on the last vertex.

• **Capture Feature.** Turns capture feature mode on. In this mode vertexes of the captured features will rendered. A new vertexes may be added by right mouse clicking on the lines. Also features shape may be changed by vertexes position changing.

• **Move Feature.** Turns move features mode on. In this mode mouse drag over the features on the map will result in features moving.

• **Cut Captured Feature.** Allows to cut currently captured features and copies them to the clipboard.

• **Copy Captured Feature.** Copies currently captured features to the clipboard.

• **Paste Feature.** Allows to paste previously copied features to the active map layer.

• **Delete Captured Feature.** Allows to delete features currently captured.

• **Release Capture.** Releases features capture.

• **Active Layer Legend.** Displays legend editor dialog. It allows to change different parameters of map layer visualization including line width, line color, line type, point type, fill color, ranges of filling and text labels.

**View Menu**

• **Pan Map.** Turns pan mode on. In this mode mouse dragging over map viewer pane will result in map panning.

• **Zoom Map In.** Turns zoom in mode on. In this mode left mouse clicking or area selection on the map viewer pane will result in map extent changing (zooming map in).

• **Zoom Out.** Turns zoom out mode on. In this mode left mouse clicking on the map viewer pane will result in map extent changing (zooming map out).

• **Zoom To Previous Extent.** Changes extent of the map to the previous state or does nothing.

• **Zoom To Active Layer.** Changes extent of the map to the extent of the currently active layer.

• **Zoom To Full Extent.** Changes extent of the map to the extent which covers all the map layers

• **Select Features.** Makes features selected on the map. Selected features will be
highlighted by the special color. There are several gis operations which may be applied to the selected features.

- **Zoom To Selection.** Changes Map extent to the extent of the selected features on the map.
- **Clear Selection.** Removes selection.
- **Feature Attributes.** Loads attribute data from the features currently pointed by user on the map.
- **Sel Feature Attributes.** Displays attributes viewer dialog and loads attribute data to it from the features being selected as a result of previous operations.
- **Refresh.** Performs rendering of a multi-layered map.

**Layer Menu**

- **New Vector Layer.** Display wizards which will guide through the process of a new vector layer creation. A new empty vector layer will be created as a result.
- **New Raster Layer.** Displays wizard which will guide through the process of a new raster layer creation. Only ASCII Arc Grid and ASCII Grass Grid formats are supported here. A new empty raster layer will be created as a result.
- **Add Vector Layer.** Adds a new vector layer to the project. Layer data will be loaded from the shape file.
- **Add Raster Layer.** Adds a new raster layer to the project. Supported formats are world image, geo tiff, ASCII Arc Grid, ASCII Grass Grid.
- **Add Postgis Layer.** Adds a new vector layer to the project. Layer data will be loaded from the postgis database (configuration parameters have to be specified).
- **Delete Layer.** Allows to delete active layer from the project.
- **Move Layer Up.** Moves layer up in the layer manager. This operation changes order of map layers rendering.
- **Move Layer Down.** Moves layer down in the layer manager. This operation changes order of map layers rendering.
- **Layer Properties.** Displays brief information about active map layer.

**Analysis Menu**

- **Measure Distance.** Allows to measure distance on the map along lines or poly-lines.
- **Measure Selected Features.** Allows to measure area, length and perimeter of the selected features.

**Tools Menu**

- **Map Query.** This tool allows to create complex queries to the selected map layer. Query is logical expression which may include the following operators: = (is equal to), <> (is not equal), > (is greater than), >= (is greater than or equal to), < (is less than), <= (is less than or equal to), AND, OR, NOT, IN (include).
- **Attributes Table.** This tool allows to view attributes for the selected area on the map. Also it supports attributes editing capabilities including such operations as undo, redo, cut, copy, paste.
- **Spatial Alternatives.** This tool is used for spatial alternatives generation. Spatial
alternative has an unique name and arbitrary number of features linked to it. Number of alternatives is not limited. All spatial alternatives have to have the same structure.

- **Network Diagram.** This tool allows to create sites and build routes between them. Routes may be created manually or generated automatically based on map of depths.

**Help Menu**

- **User's Guide.** Allows to get access to the application's user guide.
- **About.** Shows dialog box that displays general information about the software.
Main Toolbar

Main toolbar provides quick access to project management and map layers management functions of the D2M2-GIS application.

![Main Toolbar](image)

**Figure 2. Main Toolbar**

- New Project
- Open Project
- Save Project
- Close Project
- Add Raster Layer
- Add Vector Layer
- Add Postgis Layer
- Delete Layer
- Map Query
- Attributes Table

All this quick actions provide the same function as the same items in menu bar. You can place the toolbar in a convenient place for you. To do this, press the left mouse button on the left side of toolbar, and drag to the desired location and then release the mouse button.
Map View Toolbar

Map view toolbar provides quick access to basic gis functions including map zooming, panning, features selecting and attributes viewing.

![Map View Toolbar](image)

**Figure 3. Map View Toolbar**

- Pan
- Zoom In
- Zoom Out
- Zoom To Layer
- Unzoom
- Select Features
- Zoom To Selection
- Sel Feature Attributes
- Clear Selection
- Feature Attributes
- Measure Distance
- Measure Selected Features

All this quick actions provide the same function as the same items in menu bar. You can place the toolbar in a convenient place for you. To do this, press the left mouse button on the left side of toolbar, and drag to the desired location and then release the mouse button.
Map Edit Toolbar

Map edit toolbar provides quick access to features editing functions including adding, editing and moving features.

![Map Edit Toolbar](image.png)

**Figure 4. Map Edit Toolbar**

- Undo
- Redo
- Add Feature
- Capture Feature
- Move Feature
- Cut Captured Feature
- Copy Captured Feature
- Paste Feature
- Delete Captured Feature
- Active Layer Legend

All this quick actions provide the same function as the same items in menu bar. You can place the toolbar in a convenient place for you. To do this, press the left mouse button on the left side of toolbar, and drag to the desired location and then release the mouse button.
Map Viewer Pane

Map viewer pane is intended for multi-layered maps visualization. Mouse is used to control map rendering process on the pane. Map pane may functioning in one of the following mods: zooming map in, zooming map out, map panning, features selecting, features attributes viewing, distance measuring, adding features, capturing features, moving features.

To zoom map in:
1. Turn zooming map in mode on (Main Menu → View → Zoom Map In).
2. Left click on the map or select region to magnify (hold left mouse button pressed while moving the mouse).

To zoom map out:
1. Turn zooming map out mode on (Main Menu → View → Zoom Out)
2. Left click on the map to zoom it out.

To pan the map:
1. Turn map panning mode on (Main Menu → View → Pan Map).
2. Drag the map (hold left mouse button pressed while moving the mouse).

To select features on the map:
1. Turn select features mode on (Main Menu → View → Select Features).
2. Left click on feature of the active map layer to select it or specify region of selection (hold left mouse button pressed while moving the mouse).

To view features attributes:
1. Turn view feature attributes mode on (Main Menu → View → Feature Attributes).
2. Open attributes viewer (Main Menu → Tools → Attributes Table).
3. Left click on the feature of the active map layer or specify region (hold left mouse button pressed while moving the mouse). Attributes of the selected features will be displayed in the feature attributes viewer.

To measure distance on the map:
1. Turn distance measuring mode on (Main Menu → Analysis → Measure Distance).
2. Hold left mouse button pressed while moving mouse to draw line. To create poly-line click right mouse button while holding left mouse button pressed. Release left mouse button to get distance estimation.

To add a new feature:
1. Turn features adding mode on (Main Menu → Edit → Add Feature).
2. Depending on type of the layer:
1. To create point just left click on the map where point have to be created.

2. To create line left click on the map where start vertex have to be located. Move mouse to the next location on the map and left click to create a new vertex. Double click on the last vertex to finish line creation.

3. To create polygon left click on the map where start vertex have to be located. Move mouse to the next location on the map and left click to create a new vertex. At least three vertexes have to be specified to create polygon. To finish polygon creation double click on the last vertex.

To capture feature:

1. Turn features capturing mode on (Main Menu → Edit → Capture Feature).
2. Click on the feature to make it captured.
3. To change vertex position hold left mouse button pressed over the selected feature’s vertex and move mouse to the desired location. Release left mouse button to move vertex.
4. To add a new vertex right click on the line between vertexes.

To move feature:

1. Turn move feature mode on (Main Menu → Edit → Move Feature).
2. Hold left mouse button pressed over the feature and move mouse to the desired location. Release left mouse button to move feature.
Layer Manager

Layer manager displays list of the map layers loaded to the project at the moment. Each layer in the manager is presented by it's name and legend description. Layer manager allows to change visibility state and order of rendering of map layers.

![Layer Manager](image)

Figure 5. Layer Manager

To make layer active:

1. Left click on the caption of the map layer in the layer manager. It will be highlighted in the dark gray color. By default gis functions such features selecting, attributes viewing, features adding, features capturing, features moving, legend editing will be applied to the active layer.

To change rendering order:

1. Hold left mouse button pressed over the map layer caption in the manager. Move mouse to the desired location within the manager. Release left mouse button to change layer position in the list. The same affect may be reached by using Move Layer Up (Main Menu → Layer → Move Layer Up) and Move Layer Down (Main Menu → Layer → Move Layer Down) commands.

To change visible state:

1. Click check box in the caption of the selected map layer in the manager. Selected check box means that map layer is visible, deselected check box means that map layer is not visible.
**Status Bar**

Status bar is used to display additional information which may be helpful for users during working with the application. At present status bar displays only map mode which may be one of the following PAN, ZOOM IN, ZOOM OUT, SELECT, VIEW ATTRS (default mode), DISTANCE, ADD, CAPTURE, MOVE.

*Figure 6. Status Bar*
Projects Management

D2M2-GIS application uses projects to put together descriptive information (name, description, date of creation), data concerning map layers including list of selected layers, coordinate reference system (CRS) and map units as well as spatial alternatives description and network diagram structure. Projects can be saved and re-used.

![New Project Window](image)

**Figure 7. Project properties**

- **Project Name.** Name of the project. It will be displayed at the title of the application's main window.
- **Project Description.** Textual description of the project.
- **Date of Creation.** Created automatically at the moment of new project creation.
- **Selected Map Layers.** List of layers loaded to the project. New layers may be added here. Already loaded layers may be deleted.
- **Map CRS.** Coordinate reference system of the multi-layered map in WKT format. By default it is the same as CRS of the first layer loaded to the project.
- **Map Units.** Map units may be selected manually for the local CRS or will be set automatically based on the given CRS.
To create a new project:

1. Open new project properties dialog (Main Menu → File → New Project).
2. Enter project name and description.
3. Load one or more map layers to the project. To add a new layer press “Add Map Layer” button and select from the drop down menu type of the layer to add (raster layer, shape file, postgis table).
4. CRS will be set automatically based on the data from the first loaded map layer. All layers in the project have to have the same CRS.
5. Specify map units in case of local CRS.
6. Press OK button to finish a new project creation.

To open an existing project:

1. Start open project dialog (Main Menu → File → Open Project). File choosing dialog will be displayed.
2. Select project file in the file system and press OK button to load project.

To close project:

1. Execute close project command (Main Menu → File → Close Project). If project is not saved the notification will be displayed.

To save project:

1. Execute save project command (Main Menu → File → Save Project). If project is saved for the first time the file choosing dialog will be displayed to select file for project saving. Make sure that you have read and write access to the selected data folder!

To save project as:

1. Execute save project as command (Main Menu → File → Save Project As). File choosing dialog will be displayed.
2. Select file to save project and press OK button to perform saving. Make sure that you have read and write access to the selected data folder.

To edit project properties:

1. Execute edit project properties command (Main Menu → File → Project Properties). Project properties dialog will be displayed.
2. In the the project properties dialog the following parameters may be changed: project name, project description, list of the loaded map layers (new layers added or loaded layers deleted).
3. Press OK button to update the project. Make sure that you have read and write access to the selected data folder.
Application Settings

Application settings can be changed using special dialog (MainMenu → File → Settings). Current version of this dialog allows to manage application resources paths in the file system. The paths are used to search map layers during GIS project initialization. Application resources paths may be changed manually by the user or will be updated automatically during map layers loading.

To add a new path:

1. Open application settings dialog (MainMenu → File → Settings).
2. Press “Add” button and select folder in the file choosing dialog. Press “OK” button to submit selected path. A new path (if it is not already exists in the list) will be added to the list of available paths.

To edit an existing path:

1. Open application settings dialog (MainMenu → File → Settings).
2. Select path to edit in the list. Press “Edit” button and change path in the file choosing dialog. Press “OK” button to submit changes.

To delete an existing path:

1. Open application settings dialog (MainMenu → File → Settings).
2. Select path to delete in the list. Press “Delete” button to delete path from the list.
Layers Management

Some of the layers management functions are implemented in the layer manager pane. Here are described the main functions presented in the “Layer” menu including new vector layer, new raster layer, add vector layer, add raster layer, add postgis layer.

To create a new vector layer:

1. Open new vector layer creation wizard (Main Menu → Layer → New Vector Layer).
2. Specify layer title.
3. Choose layer data format (shape file or postgis table).
4. Depending on the layer data format:
   1. Select shape file in the file choosing dialog. Press OK button to specify map layer data source.
   2. Specify PostgreSQL server IP, port number, database name, schema name, user name and password for postgis database or select one of available databases. Enter a new table name (this table is used for spatial and attributive data storing). Press OK button to specify map layer data source.
5. Select (or unselect) “Load layer to map context after creation” check box.
6. Press “Next” button to continue.
7. Select layer type (point layer, line layer, polygon layer).
8. Create attributes (at least one attribute have to be created). Use add button to create a new attribute description. Attribute description includes attribute name, type (Integer, Long Integer, Real Number, String), attribute size (for strings only). Use “Delete” button to remove selected attribute description from the list.
9. If possible CRS description will be obtained from the project settings automatically. Otherwise (if project is not created yet) it should be set manually. To set CRS manually press “…” button and enter WKT description manually, load it from the file or from the postgis spatial_ref_sys table.
10. Press “Finish” button to create a new vector layer. If project is not created yet the default project will be created and a new vector layer loaded to it. Make sure that you have read and write access to the selected data folder.
To create a new raster layer:

1. Open a new raster layer creation wizard (Main Menu → Layer → New Raster Layer).
2. Specify layer title.
3. Select type of the raster layer. Only two types of raster layers may be created using this wizard: ANSII Arc Grid, ANSII Grass Grid.
4. Open file chooser and specify file which will be used for new raster layer creation (Layer Data Source).
5. Select (or unselect) “Load layer to map context after creation” check box.
6. Press “Next” button to continue.
7. Specify number of columns and rows for the new grid (integer numbers).
8. Specify coordinates of the bottom left corner of the grid. Set western (left) x coordinate and southern (bottom) y coordinate (real numbers).
9. Specify size of the square cell (real number).
10. Specify no data value (“empty”, “not applicable” or “missing” value).
11. If possible CRS description will be obtained from the project settings automatically. Otherwise (if project is not created yet) it should be set manually. To set CRS manually press “...” button and enter WKT description manually, load it from the file or from the postgis spatial_ref_sys table.
12. Press “Finish” button to create a new raster layer. If project is not created yet the default project will be created and a new raster layer will be loaded to it. Make sure that you have read and write access to the selected data folder.
To add a new vector layer to a project:
1. Open shape file chooser dialog (Main Menu → Layer → Add Vector Layer).
2. Select shape file (*.shp) to load to the project.
3. Press OK button to start map layer loading. If project is not created yet the default project will be created automatically.

To add a new raster layer to a project:
1. Open raster file chooser dialog (Main Menu → Layer → Add Raster Layer).
2. Select raster file to load to the project. The supported types of rasters are world image (*.jpg, *.jpeg, *.gif, *.tiff, *.png), geo tiff (*.gtiff), ASCII Arc Grid (*.asc), ASCII Grass Grid (*.grass).
3. Press OK button to start map layer loading. If project is not created yet the default project will be created automatically.

To add a new postgis layer to a project:
1. Open postgis table chooser dialog (Main Menu → Layer → Add Postgis Layer).
2. Select one of the available database connections. If no connection is available create a new one. To create a new database connection press “New Data” button. Enter PostgreSQL server IP, port number, database name, schema name, user name and password. Press OK button to create database connection.
3. Select map layer from the list of available layers.
4. Press OK button to start map layer loading. If project is not created yet the default project will be created.
To display active map layer properties:

1. Open map layer properties dialog (Main Menu → Layer → Layer Properties).
Map Tools

Map Query Builder

Map query builder is simple and convenient tool for creating complex queries to select features which are satisfying to the given conditions. Here are some examples of the queries:

1. \( (\text{ATTR1} \geq 100) \text{ AND } (\text{ATTR1} < 500) \)
2. \( \text{NOT} \ \text{ATTR1} > 25 \)
3. \( (\text{ATTR1} < 100) \text{ OR } (\text{ATTR1} > 500) \)
4. \( \text{ATTR1} \text{ IN } ('A', 'B', 'C') \)
5. \( (\text{ATTR1} - \text{ATTR2}) > 0 \)

*\text{ATTR1} \text{ and } \text{ATTR2} \text{ here are attribute names}

To create and execute map query:

1. Open map query builder (Main Menu → Tools → Map Query).
2. Enter query expression using available attribute names and supported operators. Select attribute in the list to display it’s acceptable values. To add attribute name or value in the expression editor double click on it in the list.
3. Press “Execute” button to execute query. As a result features (of the active map layer) which are satisfying the given expression will be selected on the map.
Attribute Data Viewer

Attribute data viewer is intended for the active map layer attributes viewing and editing. Attributes data for the selected features are displayed in a table view. It is possible to calculate basic statistical indicators for the selected numerical column.

![Map Layer Attributes](image)

**Figure 14. Attributes viewer**

To view attributes of the active map layer select features on the map and view selected features attributes (Main Menu → View → Sel Features Attributes) or:

1. Open attribute data viewer (Main Menu → Tools → Attributes Table).
2. Turn attributes viewing mode on (Main Menu → View → Feature Attributes).
3. Left click on the feature of the active map layer or specify region (hold left mouse button pressed while moving the mouse). Attributes of the selected features will be displayed in the feature attributes viewer.

To change rows order in the table click on the column header. Rows will be sorted in the ascending order. Click it again to change sorting order to descending.

To view statistics for the selected numeric column:

1. Select numeric column in the attribute data viewer.
2. Press “Statistics” button in the toolbar.

To edit attributes data:

1. Turn edit mode on by selecting “Toggle Edit Mode On/Off” button in the toolbar. All cells in the table become editable.
2. Change cell values by entering new data. Undo and redo operations may be used to cancel
or do over modifications. Selected cells values may be deleted or copied to the clipboard.

3. Press “Apply” button on the toolbar to commit changes.

4. Turn edit mode off to make table cells not editable.
Spatial Alternatives Manager

Spatial alternatives manager is intended for creation an input for the MCDA module (spatial alternatives names and associated attributive data). Data collected here may be saved and restored with the project. Spatial alternatives manager allows to create a new (empty) alternatives or delete an existing alternatives, to add or remove features to/from the selected alternative as well as select alternative’s features on the map.

To create a new spatial alternative:

1. Open spatial alternatives manager (Main Menu → Tools → Spatial Alternatives).
2. Press “New Alternative” button and enter it’s name in the displayed text field. Alternative name should be unique within the project. A new alternative will be added to the tree without child nodes.
3. Repeat step 2 to create desired number of alternatives.

To add features to alternatives:

1. Select features on the map manually or using query:
   1. To select features manually turn select mode on (Main Menu → View → Select Features) first. Then left click on feature of the active map layer to select it or specify region of selection (hold left mouse button pressed while moving the mouse).
   2. To select features using map queries open map query builder (Main Menu → Tools → Map Query) first. Than create query expression and press “Execute” button.
2. Open spatial alternatives manager (Main Menu → Tools → Spatial Alternatives) if necessary.
3. Select alternative in the tree and press “Add Features” button. Selected features will be linked to the spatial alternative. One alternative may contain features from the different vector map layers.
4. Repeat steps 1 – 3 in order to link features to all alternatives. It is important to note that spatial alternatives have to have the same structure in order to use them in the MCDA module. Same structure means that each spatial alternative contains features from all map layers which are used for spatial alternatives generation.
Created spatial alternatives may be saved and restored with the project. MCDA module may read project file in order to get spatial alternatives descriptions for the subsequent analysis.

To delete spatial alternative:
1. Open spatial alternatives manager (Main Menu → Tools → Spatial Alternatives).
2. Select alternative in the tree.

To delete features linked to a spatial alternative:
1. Open spatial alternatives manager (Main Menu → Tools → Spatial Alternatives).
2. Select layer name or specific feature in the tree.
3. Press “Delete Features” button.

To select features on the map:
1. Open spatial alternatives manager (Main Menu → Tools → Spatial Alternatives).
2. Select layer name or specific feature in the tree.
3. Press “Select On Map” button.
Network Diagram Builder

Network diagram builder is intended for creating spatially linked sites (dredge, transfer, disposal) and routes between them. This tool allows to perform integration between GIS module and D2M2-Main module. Map is used here as a bottom layer during sites and routes creation.

To create sites:

1. Open network diagram builder (Main Menu → Tools → Network Diagram).
2. Press “Add Site” button.
3. If this button is pressed for the first time the new layer creation wizard will be displayed. Enter layer name, choose layer data format (shape file or postgis table), specify map layer data source. Press OK button to create a new point layer.
4. A new site creator dialog will be displayed. Enter site name, select site type (dredge, transfer, disposal) and make site coordinates text field active. After that click on the map to create a new site. Site coordinates will be entered automatically.
5. Repeat steps 2-4 to create the new sites.
To select site on the map:
1. Open network diagram builder (Main Menu → Tools → Network Diagram).
2. Select site in the list of available sites.
3. Press “Select On Map” button.

To delete all sites:
1. Open network diagram builder (Main Menu → Tools → Network Diagram).
2. Press “Delete All” button. All sites will be deleted from the list of available sites and from the sites map layer.

To view site description:
1. Open network diagram builder (Main Menu → Tools → Network Diagram).
2. Select site in the list of available sites.
3. Site description will appear in the text area under the list.

To import sites and routes data from the D2M2-Main module project file:
1. Open network diagram builder (Main Menu → Tools → Network Diagram).
3. Select D2M2-Main project file and press OK button. Sites and routes will be loaded to the network diagram builder.

To export sites and routes to the D2M2-Main module project file:
1. Open network diagram builder (Main Menu → Tools → Network Diagram).
3. Select an existing file or enter a new file name. Press OK button to save network diagram to the file. Make sure that you have read and write access to the selected data folder.

To create routes manually:
2. Press “Add Dredge Site” button. The site selector dialog will appear.
3. Select site from the drop-down list and press OK button. Selected dredge site will be added to the route tree as a starting point of the new route.
4. Select dredge site in the route tree. Press “Add Transfer Site” button to add transfer site to the route if necessary. It is possible to add several transfer sites between starting point (dredge site) and end point (disposal site) of the route.
5. Select last site in the route and press “Add Disposal Site” button. Disposal site is end point of the route.
6. Repeat steps 2-5 to create a new routes.
7. Press “Generate Routes” button to create routes on the map. If this button is pressed for
the first time the new vector layer creation wizard will be displayed. Enter layer name, choose layer data format (shape file or postgis table), specify map layer data source. Press OK button to create a new line layer (make sure that you have read and write access to the selected data folder.). Routes will be added automatically to the layer as straight lines connecting sites.

To delete site (or sites) from the route:

2. Select site in the tree.
3. Press “Delete” button. Selected site node and all its child nodes will be deleted from the route tree. To update routes layer press “Generate Routes” button.

To create routes automatically (based on map of depths):

1. Load map of depths to the current project (or create a new project). Map of depths is raster layer in one of the following formats: ASCII Arc Grid, ASCII Grass Grid.
3. Press “Auto Generate Routes” button. Input parameters setter dialog will be displayed.
4. Select map of depths from the drop-down list. Set min acceptable depth and, if necessary, max acceptable length of the route.
5. Press OK button to start routes creation. If routes layer is not created the new layer creation wizard will be displayed. Enter layer name, choose layer data format (shape file or postgis table), specify map layer data source. Press OK button to create a new line layer (make sure that you have read and write access to the selected data folder.).

![Auto Generate Routes](image)

*Figure 17. Routes generator input parameters.*

To change route shape:

1. Turn capture feature mode on (Main Menu → Edit → Capture Feature).
2. Make routes layer active in the layer manager (by clicking on its capture).
3. Click on the route segment to capture it.
4. Use right mouse button to add new vertexes.
5. Press left mouse button on the selected vertex and hold it while moving mouse to change vertex position.
6. Repeat steps 3-5 for each route segment which have to be updated.

Figure 18. Auto generated routes.

To get acceptable distance values (during routes generation) use “Measure distance” tool (Measure distance along a line or poly-line).

Use attributes viewer & editor tool to get acceptable values of depth.
Network Diagram Builder – Example of Use

1. Add vector layer to an empty project (Main Menu → Layer → Add Vector Layer). As an example use r_road.shp. The default project will be created automatically.

2. Open network diagram builder (Main Menu → Tools → Network Diagram). Select sites pane.

3. Press “Import Model” button and select D2M2-Main module project file. As an example use lps-d2m2-working.drg. Press OK button to start loading data from the file.

4. The new layer creation wizard will be displayed. Enter layer name (ex: sites), choose layer data format (ex: shape file), specify map layer data source (ex: slayer). Press OK button to create a new point layer. Sites will be created and layer will be added to the project automatically.

5. Select routes pane in the network diagram builder.

6. Press “Generate Routes” button. The new layer creation wizard will be displayed. Enter layer name (ex: routes), choose layer data format (shape file), specify map layer data source (ex: rlayer). Press OK button to create a new line layer. Routes will be created and layer will be added to the project automatically.

Figure 19. Network Diagram Manager - Example of use.